Quiesced Snapshot of Instance Cannot Be Created

Product version: 11.0

Last modified: 06 February 2024

Problem

The following error message appears:

Quiesced (application-aware) snapshot of this instance cannot be created.

Background

When the application-aware mode is enabled, the snapshot works as follows:

  • NAKIVO Backup & Replication injects a runtime VSS Driver into the instance.

  • NAKIVO Backup & Replication requests the VSS Driver to create a quiesced snapshot.

  • VSS Driver uses VSS inside a Windows instance to freeze I/O requests of applications inside the OS.

  • If OS quiescing fails to create an application-consistent snapshot, NAKIVO Backup & Replication displays this error.

Possible Cause

The error may be caused by:

  • Credentials

    • Incorrect credentials to the instance

    • Insufficient level of permissions

  • Instance access:

    • Incorrect configuration of the instance security group

    • Incorrect Windows firewall configuration inside the instance

  • Instance configuration:

    • Incorrect configuration of the instance OS

Solution

  1. Credentials. Verify that:

    • You are using the right credentials for the instance.

    • The credentials you are using have administrative permissions.

  2. Instance access. Verify that:

    • Instance security group allows access to TCP ports 445 and 9445 from the Director.

  3. Instance configuration. Verify that:

    • Your instance OS is supported for EC2 application-aware processing.

    • The "File Services" or "File and Storage Services" role is enabled in the instance.

    • Default administrative shares are enabled in the instance.

    • The SMB (1.x, 2.x, 3.x) protocol is enabled in the instance.