VM-Level Job Failure

Product version: 11.0

Last modified: 11 June 2024

Problem

VM processing fails with the following error:

Internal error has occurred while backing up/replicating/recovering the VM.

Possible Cause

Closed Ports

NAKIVO Backup & Replication requires certain TCP ports to be open for successful VM processing. Refer to the Deployment Requirements article for more details. 

Verify that: 

  • The required ports are not used by other applications.

  • The required ports are not blocked.

  • The ports are accessible from the appropriate endpoints.

Server Outage

  • The source or target host might be disconnected or powered off.

  • The source or target Transporter might be disconnected or powered off.

Make sure that all the hosts and Transporters are available.

File System Issues

With a default block size of 1 MB, VMFS3 does not support files larger than 256 GB. VM disks larger than 256 GB will generate an error.

If this problem occurs on the source datastore, migrate your VM to a datastore that supports large files (for example, VMFS5).

If this problem occurs on the target datastore, use another datastore as a target.

I/O Journal Issues

For real-time replication jobs, this error may also be caused by the following:

  • Journal disks are deleted.

  • Journal disks cannot be opened on time due to inaccessible datastore or VDDK issues.

  • Journal disk size equals or exceeds 2TB and the source VM disk is on the BusLogic SCSI controller with the disk size <2TB.

reference point is missing

I/O Filter Daemon

The issue can occur in case host parameters, UserVars.NbrFilterKey (Transporter's master password) and UserVars.NbrFilterUUID (Transporter UUID) are removed or edited. Restart the I/O filter daemon to reload these parameters.

Missing Reference Point

For real-time failover jobs, this error may also be caused by the following:

  • The reference recovery point was manually deleted from the replica VM snapshot manager.

  • Real-time replication (RTR) settings may create conflicting recovery points if the job is stopped and restarted multiple times without recreating a valid reference point.

  • Creating a new RTR job for the same source VM or mapping the replica VM to a new job without recreating a valid reference point may lead to inconsistencies.

  • The datastore hosting the journal or snapshot is inaccessible or encounters I/O issues.