Supported Platforms

NAKIVO Backup & Replication provides data protection for the following platforms:

  • VMware vSphere v4.1 - v7.0.2
  • VMware Cloud Director v10.2.1
  • Microsoft Server with a Hyper-V role 2019, 2016, 2012R2, 2012
  • Amazon EC2
  • Nutanix AHV v5.10, v5.15, 5.20 (LTS)
  • Microsoft Windows Server 2019, 2016, 2012R2, 2012, 2008R2
  • Microsoft Windows 10 Pro
  • Linux Servers and workstations (see Physical machine requirements)
  • Microsoft 365 (Exchange Online, OneDrive for Business, SharePoint Online)
  • Oracle Database (RMAN)

Notes

  • To learn about limitations of NAKIVO Backup & Replication related to supported platforms, refer to the Platform Limitations section of the latest Release Notes.

  • To add a supported platform to the NAKIVO Backup & Replication, make sure that your system has been updated with the latest patch and all the necessary requirements are met.

Find the necessary requirements below:

Hypervisor Requirements

To provide data protection for your virtual environments, make sure the following requirements are met:

VMware vSphere

Microsoft Hyper-V

  • Full GUI installation of Windows Server is required.
  • Full administrative permissions are required.
  • Default administrative shares must be enabled on Hyper-V hosts.
  • The "File server" role must be enabled on Hyper-V hosts.
  • The SMB 2 protocol should be enabled on Hyper-V hosts.

Nutanix AHV

  • User admin or cluster admin permissions are required.

Physical Machine Requirements

To provide data protection for Windows physical machines, make sure they meet the following hardware and software requirements:

Hardware

  • CPU: x86_64
  • RAM: At least 1 GB
  • Firmware: BIOS or UEFI
  • Partition table: MBR or GPT
  • Disk: up to 64 TB in size

Software

  • Supported Windows operating systems:
    • Microsoft Windows Server 2019 (x64)
    • Microsoft Windows Server 2016 (x64)
    • Microsoft Windows Server 2012R2 (x64)
    • Microsoft Windows Server 2012 (x64)
    • Microsoft Windows Server 2008R2 (x64)
  • Supported workstations:
    • Microsoft Windows 10 Pro (x64)
  • Supported Windows File Systems:
    • NTFS
    • ReFS
  • Physical machines should be accessible over the network.
  • Administrative credentials should be provided to the physical machine.
  • PowerShell must be installed.
  • SMBv2 or higher version of SMB protocol must be enabled. In case a firewall is enabled, the corresponding rule for SMB-in needs to be enabled too.
  • Selected users should have permissions to "Log on as a batch job".
  • Default administrative shares must be enabled on the physical machine and accessible over the network.
  • Supported Linux operating systems:
    • Ubuntu v16.04-20.04 (x64)

    • RHEL v7.4-8.3 (x64)

    • SLES v12 SP3 - v15 SP2 (x64)

    • CentOS v7.0-8.0 (x64)

    • Supported workstations:

    • Ubuntu 18.04 (Desktop) LTS, 64-bit

    • Ubuntu 20.04 (Desktop) LTS, 64-bit

  • Supported Linux File Systems:

    • NTFS

    • Ext2

    • Ext3

    • Ext4

    • FAT32

    • XFS

    • Linux SWAP

    • ReiserFS

  • Connection to the following TCP ports should be allowed by the firewall of the target system:
    22 – Used by SSH for secure logins, file transfers (scp,sftp) and port forwarding.
    9446 – Used by NAKIVO Backup & Replication to communicate with the server.

  • openssh-server package should be installed.
  • sshd service should be running.
  • rootlogin overssh should be enabled if you use the root user. Check the /etc/ssh/sshd_config file to have a line: PermitRootLogin yes. Refer to Linux vendor documentation for more details.
  • /etc/pam.d/bhsvc file with special permissions provided to the Transporter service is required. Refer to the Required Permissions for Linux Recovery Server knowledge base article for details.
  • selinux configuration should be set to disabled if present. Refer to the File Recovery: Empty Disk knowledge base article for details.
  • PasswordAuthentication should be set to "Yes".
  • If you add a physical machine to the NAKIVO Backup & Replication inventory with a non-root account, the following is required:
    • sudo must be installed on the physical machine.

    • disable requiretty for non-root user accounts. Update the etc/sudoers file to have a line:Defaults !requiretty

Public Cloud Requirements

Refer to Required AWS IAM Permissions for Amazon EC2 for details.

Note
There is also an option for granting full IAM permissions for the application.

Microsoft 365 Requirements

To provide data protection for your Microsoft 365, the following requirements must be met:

  • Exchange Online must be purchased as a part of the Microsoft 365 plan or a standalone service.
  • The required API permissions must be provided to NAKIVO Backup & Replication. Refer to Required API Permissions for Microsoft 365.
  • For automatic enabling of the "Site Collection Administrator" role, a Microsoft 365 account user must have the "SharePoint admin" or "Global admin" role. This is required for backing up and recovery of SharePoint Online sites.

  • Two-factor/multi-factor authentication must be disabled in SharePoint Online administrator account.

  • Microsoft 365 account must be accessible over the network.
  • To backup and restore Microsoft 365 services, a Transporter should be installed on one of the following operating systems:

Windows

  • Windows Server 2019 Standard (x64)
  • Windows Server 2016 Standard (x64)
  • Windows Server 2012 R2 Standard (x64)
    • Update for Windows Server 2012 R2 (KB3179574)
  • Windows Server 2012 Standard (x64)
  • Windows Server 2008 R2 Standard (x64)
  • Windows 10 Pro (x64)
  • Windows 8 Professional (x64)
  • Windows 7 Professional (x64)

Linux

  • Ubuntu 18.04 Server (x64)
  • Ubuntu 16.04 Server (x64)
  • SUSE Linux Enterprise Server 12 SP3 (x64)
  • Red Hat Enterprise Linux 7.6 (x64)
  • Red Hat Enterprise Linux 7.5 (x64)
  • Red Hat Enterprise Linux 7.4 (x64)

NAS
Refer to Deployment Requirements to see the list of supported NAS devices.

Note
ARM-based NAS devices and FreeNAS devices are not supported for backup and recovery of Microsoft 365 accounts.

Oracle Database Requirements

To provide data protection for your Oracle database, make sure of the following:

  • Oracle database is accessible over the network.
  • Provided Oracle database credentials have sufficient permissions to be used by the product.
  • Provided OS credentials for the Oracle database have sufficient permissions to be used by the product.
  • Oracle database must be set to ARCHIVELOG mode to create backups.

Supported operating systems:

  • Windows Server 2016 Standard (x64)
  • Windows Server 2012 R2 Standard (x64)
    • Update for Windows Server 2012 R2
  • Windows Server 2012 Standard (x64)
  • Windows Server 2008 R2 Standard (x64)

Supported Oracle Database release versions:

  • Oracle Database 19c
  • Oracle Database 18c
  • Oracle Database 12c R2
  • Oracle Database 11g R2