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Product Version: 7.4
Last Modified: 28 Dec 2017

Contents

Problem

Flash VM boot or screenshot verification fails with an error.

Background

NAKIVO Backup & Replication uses iSCSI technology to connect VM disks stored in the backup to a target hypervisor: an ESXi host or a Hyper-V server.
VM disks are exposed by the Transporter which is assigned to Backup Repository and mounted to the target hypervisor host.
In turn, the disks are mounted to the hypervisor host and presented to the VMware VM as RDM disks in virtual compatibility mode, or to the Hyper-V VM as virtual disks.
The most common reasons that prevent the feature from working successfully are listed below:

iSCSI Bindings on ESXi Hosts
ESX/ESXi hosts allow binding the software iSCSI adapter (HBA) to specific VM Kernel network(s).
If such binding is configured for an ESXi host used for Flash VM Boot, connectivity between the host and the Transporter might not be available at the iSCSI layer.
If an iSCSI binding is configured for a host which you plan to use as a target for Flash VM Boot, verify the connectivity at the iSCSI layer.


iSCSI Port Busy on Transporter
NAKIVO Backup & Replication uses TCP port 3260 to expose iSCSI targets to ESXi hosts.
If the TCP port 3260 is busy on the machine where NAKIVO Backup & Replication Transporter is installed, the feature will not work.
It is not possible to change the default port number since VMware ESXi hosts are always using TCP port 3260.

Windows Firewall Blocking iSCSI
On some Windows Server systems, the firewall is configured to prevent outbound iSCSI connections.
If the firewall has this configuration, Flash VM Boot will not be functional.

iSCSI Initiator Service Not Running
NAKIVO Backup & Replication requires Microsoft iSCSI Initiator service to be enabled and running on a target Hyper-V host.
If the service is not running, the Flash VM Boot will not be available with such target host.

Troubleshooting VMware Flash VM Boot

Please follow the steps below to troubleshoot NAKIVO Backup & Replication Flash VM Boot for VMware virtual machines.

Root Cause Analysis

iSCSI Bindings on ESXi Hosts

Use vSphere client to check if you have iSCSI bindings in your ESXi host:

  1. Log in to the ESXi host.
  2. Go to Configuration  -> Storage Adapters.
  3. Locate iSCSI Software Adapter and click Properties:
    iSCSI Software Adapter
  4. Click on Network Configuration and check VMkernel Port Bindings.
    If you have iSCSI bindings, you should see something similar to this:
    VMkernel Port Bindings 

iSCSI Port Busy on Transporter

In most cases, iSCSI port is busy when NAKIVO Backup & Replication is running on a NAS and there are iSCSI targets already exposed from this NAS.
To check if TCP port 3260 is busy, perform the following steps:

  1. Log in to the system console of your NAS or server where NAKIVO Backup & Replication is installed.
  2. Run the following console command: netstat -ant
  3. Check if the command output contains TCP port 3260.

If the command output contains TCP port 3260, this port is already in use and cannot be used by NAKIVO Backup & Replication.

Windows Firewall Blocking iSCSI

If your ESXi host does not have iSCSI bindings, please check if your Transporter is installed on Windows.
If yes, please check your firewall settings.

Solution

iSCSI Bindings

Transporter VM is Running on the ESXi host which is Used for Flash VM Boot

Configure the Transporter to have access to iSCSI targets:

  1. Create a new VM network (or use an existing one that has a connection to VMkernel network used for iSCSI traffic).
  2. Add a new network adapter to the VM with the Transporter, which will be used for Flash VM Boot.
  3. Configure a static (or dynamic) IP for the newly created adapter.
  4. Create a new VMkernel network on the ESXi host (or use an existing VMkernel network on the given NIC).
  5. Add binding to the software iSCSI to this VMkernel.
Transporter is not Running on the ESXi host which is Used for Flash VM Boot

If an ESXi host has a non-bridged NIC, which has connectivity to the Transporter:

  1. Create a new VMkernel network on the ESXi host (or use an existing VMkernel network on the given NIC).
  2. Add binding to the software iSCSI to this VMkernel.

If an ESXi host has an unused NIC, which has connectivity to the Transporter:

  1. Create a new VMkernel network and a new vSwitch.
  2. Add binding to the software iSCSI to this VMkernel.

If an ESXi host has bridged NICs, which cannot participate in binding

  1. Create a new VMkernel network (or use an existing one) on the ESXi host.
  2. Enable SSH access to the ESXi host
  3. Run the following command via SSH on the target host to create binding: esxcli iscsi networkportal add -n vmkX -A vmhbaY -f 1
    Where vmkX is the ID of the created VMkernel network, and vmhbaY is the ID of the software iSCSI HBA (usually it’s vmhba34).

iSCSI Port Busy on Transporter

If TCP port 3260 is busy on the machine where NAKIVO Backup & Replication Transporter is installed, do either of the following:

  • Remove existing 3rd party iSCSI targets exposed on this port, or
  • Reconfigure existing 3rd party iSCSI targets to use a different port.

Windows Firewall

If you are using NAKIVO Backup & Replication on Windows and firewall is blocking iSCSI traffic, please follow the steps below:

  1. Open the Command Prompt as Administrator.
  2. Run the following commands:

    netsh advfirewall firewall add rule name="iSCSI" dir=in action=allow protocol=TCP localport=3260

    netsh advfirewall firewall add rule name="iSCSI" dir=out action=allow protocol=TCP localport=3260

Other Issues

If you do not have network adapter iSCSI bindings and do not have issues with Windows firewall, contact us and provide detailed information:

  1. Create a support bundle.
  2. Take screenshots of your iSCSI adapter configuration and networking.
  3. Contact  NAKIVO support and provide the collected information.

Troubleshooting Hyper-V Flash VM Boot

Please follow the steps below to troubleshoot NAKIVO Backup & Replication Flash VM Boot for Hyper-V virtual machines.

Root Cause Analysis

Microsoft iSCSI Initiator Service not Running

Please follow the steps below to determine whether Microsoft iSCSI Initiator Service is running:

  1. Log in to the Hyper-V server.
  2. Start the Services snap-in:
    • On Windows Server 2016, click Start, in the Start Search box enter services.msc, and then press Enter.
    • On Windows Server 2012 and Windows Server 2012 R2, go into the Desktop mode, hover the pointer over the lower left corner of the screen, right-click the Start pane, in the menu that opened click Run, enter services.msc in the Run box, and then press Enter.
  3. In the list of services, locate the Microsoft iSCSI Initiator Service and check its status. The service must be running.

 

iSCSI Port Busy on Transporter

Please refer to the subsection above for the root cause analysis.

Windows Firewall Blocking iSCSI

If the NAKIVO Backup & Replication Transporter is installed on Windows, please check your firewall settings.

Solution

Microsoft iSCSI Initiator Service not Running

Please follow the steps below to run the Microsoft iSCSI Initiator Service:

  1. In the Services snap-in, locate the Microsoft iSCSI Initiator Service and double-click it.
  2. The Microsoft iSCSI Initiator Service Properties dialog opens. Make sure Automatic or Manual is chosen for the Startup type, and then click Start.

iSCSI Port Busy on Transporter

Please refer to the subsection above for a solution.

Windows Firewall Blocking iSCSI

If you are using NAKIVO Backup & Replication on Windows and firewall is blocking iSCSI traffic, please follow the steps below to enable ports necessary for iSCSI network traffic:

  1. Open the Command Prompt as Administrator.
  2. Run the following commands to allow the necessary ports:
netsh advfirewall firewall add rule name="iSCSI" dir=in action=allow protocol=TCP localport=3260
netsh advfirewall firewall add rule name="iSCSI" dir=out action=allow protocol=TCP localport=3260

Other Issues

Please refer to the subsection above.

 

 

 

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